Фърмуер 2024 - версия 2.3.1(164)

Новата версия на OpenSprinkler-Фърмуер С разширение за Аналогова сензорна платка.

ЗАБЕЛЕЖКА: Тази статия се отнася до OpenSprinkler 3 / 3.2 / 3.3 и OSPi

Тази версия е базирана на оригиналния фърмуер на производителя (OpenSprinkler.com), но е мой допълнително коригирани.

Новото е:

  • Достъп до облак чрез Openthings.io Cloud Token (НОВО: СЪЩО OSPi !!!)
  • Групиране на зони
  • Нов контрол на напояването чрез нов график
  • Нов специфичен за времето метод: Месечни стойности
  • Ексклузивно тук: API за аналогови сензори


Промени във версията

Моля, обърнете внимание: Няма поддръжка от производителя (от САЩ) за модифицирания фърмуер, само чрез това страница за поддръжка!

НОВО в 164:

  • OSPi със скрипт за стартиране на systemd. Инсталира се и се активира автоматично, когато актуализирате фърмуера със „sudo ./updater.sh“.
  • корекция на https станция
  • По-кратко време за изчакване за дистанционни сензори, за да се избегне блокиране.

НОВО в 163:

  • Резе на OS3x: Регулиране на ключалката на разширителя на зоната за коригиране на грешки
  • OSPi: OSPi Поправка на грешка освобождаване/изтриване на паметта
  • OSPi: Коригира датата на забавяне на дъжда

НОВО в 162:

  • Версия на корекция на грешки: Корекция на внедряването на MQTT парола, вече са възможни по-дълги пароли

НОВО в 161:

  • Версия на корекция на грешки: Корекция на препълване на буфера в дисплея на регистъра на сензора на диаграмите

НОВО в 160:

  • OSPi: OpenThingsFramework. Това сега го дърпа OSPi версия на OpenSprinkler Версия 3.x същата и позволява отдалечен достъп чрез OTC токени! За подробности вижте „Отдалечен достъп чрез Openthings.io Cloud“ по-долу
  • OSPi: Подкрепа за OSPi 1.6 2xADS1115
  • MQTT: Хост, потребителско име и парола вече са по-дълги: Хост: 100, Потребител: 50, Парола 100 знака
  • MQTT: Подобрена обработка, четенето с нулеви стойности вече не чете следната стойност
  • OS3x: По-добро откриване на мрежовите адаптери ENC28J60/W5500

НОВО в 153:

  • Цифров шумов филтър за аналоговите входове на „аналоговата сензорна платка“.
  • Подобрено управление на MQTT абонаменти

Пълният списък на всички промени може да бъде намерен в GitHub

ИЛИ официалния фърмуер 2.2.0: Тук

A. OpenSprinkler 3.0 - 3.3:

!! Първо архивирайте вашата конфигурация!!

(03.06.2024) Изтеглете новия (модифициран) фърмуер 2.3.1(164): Тук

Точните инструкции за инсталиране на ЕДНА актуализация можете да намерите тук: Ето как работи актуализацията на фърмуера

B. OSPi

!! Първо архивирайте вашата конфигурация!!

OSPi Фърмуер, който да компилирате сами!


Изходният код е достъпен тук:
https://github.com/opensprinklershop/OpenSprinkler-Firmware
https://github.com/opensprinklershop/OpenSprinkler-App

Ето как да продължите

1. Отдалечен достъп чрез Openthings.io Cloud

Функцията е напълно обяснена тук.

2. Групиране на зони

Тази нова функция замества старата последователна функция, която ви позволява да контролирате дали зоните да се поливат едновременно или последователно.

С груповата функция (това са буквите на веригите), зоните с една и съща група (напр. всички зони с група A) работят една след друга, но други зони с различни групи (напр. с групи A, B и C) се изпълняват едновременно. Регулира се с предавката.

Също ново: Използвайте менюто долу вдясно, „Опции за редактиране“, след това „Система“ и „Поръчка на станции по групи“, след което зоните ще бъдат сортирани по групи.

Групите се определят тук:

Групата P представлява специален случай: всички зони с група P се поливат едновременно.

3. Метод, специфичен за времето: месечни стойности

С този метод контролът на напояването може да се регулира чрез предварително зададени месечни стойности.

4. API за аналогови сензори

Функцията е напълно обяснена тук

20 мнения за “Фърмуер 2024 - версия 2.3.1(164)"

  1. Улф Кличе
    Улф Кличе казва:

    За съжаление рестартирайте моя OpenSprinkler постоянно след импортиране на най-новия фърмуер 2.3.0. Wifi връзка -> NTP синхронизация -> Проверка на времето -> Рестартиране

  2. Франк Уейер
    Франк Уейер казва:

    Здравейте,
    Инсталирах новия фърмуер 2024 – версия 2.3.0 (139). Работи перфектно.
    Единственият път, когато Batten не работи, е когато искам да сменя парола OpenSprinkler ASB (без реакция при натискане).
    Ако задам паролата за отворена врата на друга (за простата версия Open Sprinkler), тя вече не работи OpenSprinkler ASB (черен е отстрани OpenSprinkler ASB и не отива по-нататък).
    Поздрави, Франк

  3. Франк Уейер
    Франк Уейер казва:

    Здравейте,
    Имам новия фърмуер – версия 2.3.0. (140) играе. Само че е същото като преди. (В OpenSprinkler ASB летвата не работи или е черна и не става по-нататък. )
    При работа от интернет, дори и от разстояние, всичко работи.
    Поздрави, Франк.

    • Admin
      Admin казва:

      Здравейте, това не се дължи на фърмуера, а по-скоро на приложението. Версията е актуализирана в Google Playstore и Apple Appstore, моля, проверете дали имате и текущата версия.

    • Франк Уейер
      Франк Уейер казва:

      Здравейте,
      Благодаря ти. Да, работи веднага с вашия мобилен телефон. Но за съжаление ми показва „несъвместим“ на таблета. Това е Samsung Galaxy Tab A (2016). Можете ли да промените нещо в приложението, така че да работи както преди?
      Поздрави, Франк.

  4. Франк Уейер
    Франк Уейер казва:

    Здравейте, благодаря ви много за текущия APK. Моят таблет все още има версия на Android 8.1.0. Когато отворя APK, получавам съобщение за грешка: „Възникна грешка при анализиране на пакета. “. (На мобилния си телефон имам индикация за точността на неизвестни приложения.)
    Мога ли по някакъв начин да заредя APK?
    Поздрави, Франк.

    • Admin
      Admin казва:

      Здравей Франк, страхувам се, че не може да се направи нищо повече. Вашият таблет е твърде стар, Android 8.1.0 вече не се поддържа, сега сме на Android 15. Това би било като да се опитвате да използвате Windows XP на компютър, но вече не работи много.
      Въпреки това опитах отново и коригирах отново APK в папката на фърмуера. Моля, опитайте тази версия отново

  5. Франк Уейер
    Франк Уейер казва:

    Здравейте, първо трябваше да изтрия стария, после го преинсталирах и работи перфектно!!! Благодаря много !!!
    Поздрави, Франк.

  6. Kay
    Kay казва:

    Здравейте. Опитвам се да накарам този нов фърмуер да работи във виртуална машина. За съжаление инсталацията е неуспешна, защото няма GPIO във виртуалната машина и затова получавам много съобщения за грешка. Също така не ми трябва GPIO, защото клапаните се управляват през MQTT. Има ли начин да инсталирате най-новия фърмуер без да използвате GPIO?

    Благодаря предварително
    Поздрав
    Kay

    • Admin
      Admin казва:

      Добре, но защо? Можете просто да използвате Homeassist и да го използвате за управление на клапаните.
      Ако искате да персонализирате това, не се колебайте да го направите. Софтуерът е с отворен код и е в Github.

    • валдир
      валдир казва:

      „Актуализацията на фърмуера може да се извърши САМО през WLAN (за версии по-ниски от 2.2.0.105).“ А за версиите по-горе? Как работи актуализацията през Ethernet, тъй като страницата за актуализация obv. не работи през Ethernet и винаги излиза със съобщението „проверете ключа на устройството“ (хеш и изчистване)?

      • Admin
        Admin казва:

        Да, над тази версия актуализацията на фърмуера работи и с Ethernet LAN. „Проверете ключа на устройството“ означава, че паролата е грешна.

  7. Gregor
    Gregor казва:

    През уикенда пробвах разширените MQTT пароли - потребителският интерфейс се заби (черен екран)! След това видях 161 - инсталирането му също проработи, но потребителският интерфейс все още висеше -> възстановяване на фабричните настройки. Просто нямам време - трябва ли жетоните от 100 знака да вървят със 161?

Оставете коментар

Вашият е-мейл адрес няма да бъде публикуван. Задължителните полета са отбелязани с * маркиран

Този уебсайт използва Akismet за намаляване на спама. Научете повече за обработката на данните за коментарите ви.